Exercices sur la fonction SI avec les fonctions ET / OU

Objectifs : - Utiliser la fonction logique SI.
                  - Utiliser la fonction ET imbriquée avec la fonction SI.
                  - Utiliser la fonction OU imbriquée avec la fonction SI.


L’expression conditionnelle  avec la fonction Si()

Syntaxe  = Si(condition;valeur_si_vrai;valeur_si_faux)

Exemple : la fonction ci-dessous 



Vérifie si la valeur contenue dans la cellule A2 est supérieure ou égale à 10. Si oui, elle affiche « Admis » dans la cellule où la formule a été tapée, c’est à dire B2 sinon, elle affiche « Recalé ».

Utilisation de la fonction ET 


Syntaxe  = ET(condition_1; condition_2;… ; condition_n)

 Retourne VRAI si toutes les conditions sont vérifiées, FAUX sinon

Exemple :  =SI(ET(A2>0;A2<=20);B2;"Attention Erreur dans la note!");

Affiche le contenu de la cellule B2 (l’observation) si le contenu de la cellule A2 est entre 0 et 20, et le message "Attention Erreur dans la note!" dans le cas contraire.

Remarque : la fonction OU a la même syntaxe.

EXERCICES SUR LA FONCTION SI() :



Remarque : tous les exercices traitent de la fonction SI et sont de difficulté croissante.

Exercice 1 :

A/ Dans la colonne "Escompte", si le montant de la commande client est supérieur à 10 000 Euros afficher "OUI" sinon afficher "NON".   
   
B/ Dans la colonne D, calculez le montant de l'escompte, sachant que ce dernier s'élève à 2%.





Exercice 2 :

Afficher dans la colonne 3 le taux de TVA correspondant au code inscrit en colonne 2 sachant
que :

CODE TVA 1 = 5%
CODE TVA 2 = 19,60%


Exercice 3 : même chose que l’exercice précédent (en plus difficile)

Afficher dans la colonne C le taux de TVA correspondant au code inscrit en colonne B. 
CODE TVA1 = 2.10%
CODE TVA2 = 5.50%
CODE TVA3 = 19.60%

Exercice 4 :

Calculez en en colonne 5 la prime accordée aux salariés sachant que :

a) Les salariés sans enfants n'y ont pas droit
b) Cette prime est fonction du nombre d'enfants.
c) La prime s'élève à 50 Euros par enfant pour les salariés avec 1 ou 2 enfants et à 70 Euros par enfant pour les salariés ayant 3 enfants ou plus.



Exercice 5 :

1)  Nous allons accorder une prime aux représentants ayant dépassé 30 000 Euros de chiffre d'affaires au cours du trimestre. Cette prime s'élève à 1% du chiffre d'affaires. 

2)  Dans le format d’affichage de la dernière colonne, si pas de prime, on affichera le caractère " - " à la place du 0.




3)  Faire un graphique (histogrammes) qui montre pour chaque représentant, les ventes qu’il a réalisées pour chaque mois, le total trimestriel et la prime qu’il a eu.

Exercice 6 : Trophée

Nous allons remettre un trophée  aux acteurs ayant, soit tourné plus de 15 films, soit ayant dépassé les 200 millions d'entrées. Faire afficher "Trophée" dans la colonne E pour les acteurs susceptibles de le recevoir.




                                                   

Article plus récent Article plus ancien

Leave a Reply